Gravity Payments website unavailable for some users

Incident Report for Gravity Payments

Resolved

We have resolved the issue and gravitypayments.com is available for all users reliably.

Thank you for your patience.
Posted Jun 25, 2025 - 20:09 PDT

Investigating

Gravity Payments website intermittently unavailable for some users. We are aware of the issue and are working to resolve it as quickly as possible.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jun 25, 2025 - 17:56 PDT