Investigating issues with availability of dashboard.gravitypayments.com

Incident Report for Gravity Payments

Resolved

This incident has been resolved and availability of dashboard.gravitypayments.com has been restored.
Posted Jan 15, 2026 - 14:41 PST

Investigating

Access to dashboard.gravitypayments.com is currently unavailable.

We are currently investigating the issue and will update this page with more information soon.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jan 15, 2026 - 14:36 PST
This incident affected: Gravity Dashboard.