Clover - Service Disruption

Incident Report for Gravity Payments

Resolved

This incident has been resolved by Clover.

If you still need support, please reach out to our team at support@gravitypayments.com or call tel :8667014700.
Posted Oct 13, 2025 - 10:24 PDT

Investigating

We are currently investigating an issue affecting some Clover payment devices connected through Emergepay. Merchants may experience intermittent or failed device connections impacting transaction processing. Our team is actively working with Clover to identify the cause and restore normal operation as quickly as possible.

If you need support, please reach out to our team at support@gravitypayments.com or call tel :8667014700.

Thank you for your patience while we work to resolve this.
Posted Oct 13, 2025 - 09:03 PDT
This incident affected: emergepay.