We have resolved these small amount of errors. We continue to monitor for any issues impacting merchants.
If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jun 17, 2025 - 15:00 PDT
Update
We are observing a small number of merchants with expired authorizations to CloverⓇ as a result of yesterday's service disruption. We are currently working to fix those accounts.
Posted Jun 13, 2025 - 06:00 PDT
Monitoring
CloverⓇ has confirmed the issues impacting your payments device and cloud applications has been resolved. You are now able to resume accepting payment through your Clover device as normal.
If you continue to experience issues, please reach out to our support team at support@gravitypayments.com for assistance.
Thank you for your patience and continued business.
The Gravity Support Team
Posted Jun 12, 2025 - 14:09 PDT
Investigating
We are currently investigating the issue and will update this page with more information soon.
If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.