Service Disruption

Incident Report for Gravity Payments

Resolved

This incident has been resolved.
Posted Aug 30, 2026 - 01:26 PDT

Investigating

We are still working to resolve issues causing some payments to fail.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Aug 30, 2026 - 00:09 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 29, 2026 - 22:26 PDT

Identified

We are currently investigating the issue and will update this page with more information soon.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Aug 29, 2026 - 21:39 PDT
This incident affected: Processing Services.