Gravity Dashboard - Two-factor authentication issues

Incident Report for Gravity Payments

Resolved

This incident has been resolved.

If you still need support, please reach out to our team at support@gravitypayments.com or by calling us at 866-701-4700.
Thank you for your patience while this issue is being resolved.
Posted Apr 21, 2025 - 08:54 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 21, 2025 - 08:54 PDT

Monitoring

We are seeing successful two-factor authentication attempts via SMS at this time.

If you still need support, please reach out to our team at support@gravitypayments.com or by calling us at 866-701-4700.
Thank you for your patience while this issue is being resolved.
Posted Apr 21, 2025 - 08:13 PDT

Investigating

We are currently experiencing intermittent service disruptions with our two-factor authentication services. As a result, you may have issues accessing Gravity Dashboard at this time.
If you need support, please reach out to our team at support@gravitypayments.com or by calling us at 866-701-4700..
Thank you for your patience while this issue is being resolved.
Posted Apr 21, 2025 - 08:07 PDT
This incident affected: Gravity Dashboard.