USAePay - Service Disruption

Incident Report for Gravity Payments

Resolved

Processing transactions with USAePay has remained stable for over 24 hours, and no further errors have been observed.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel :8667014700.
Posted Jul 05, 2025 - 16:35 PDT

Monitoring

USAePay has implemented a fix, and we have observed no further timeouts. We are continuing to monitor for any further errors.

If you are having any difficulties processing transactions, please contact our support team at support@gravitypayments.com or call tel: 8667014700.
Posted Jul 04, 2025 - 08:19 PDT

Investigating

We are aware of an issue with USAePay transaction processing. We will update this page with more information soon.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel :8667014700.
Posted Jul 04, 2025 - 07:09 PDT
This incident affected: Processing Services.