USAePay - Service Disruption

Incident Report for Gravity Payments

Resolved

This incident is now resolved.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jul 03, 2025 - 22:28 PDT

Monitoring

We are aware of an issue with USAePay transaction processing and are currently monitoring the issue. We will update this page with more information soon.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jul 03, 2025 - 13:39 PDT
This incident affected: Processing Services.