Investigating issues processing transactions with emergepay

Incident Report for Gravity Payments

Resolved

This incident has been resolved.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jan 21, 2026 - 14:49 PST

Investigating

We are currently investigating the issue and will update this page with more information soon.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Jan 21, 2026 - 14:36 PST
This incident affected: emergepay.