Investigating issues causing some transactions to fail

Incident Report for Gravity Payments

Resolved

This incident has been resolved.

If you continue to have difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Sep 02, 2026 - 11:45 PDT

Monitoring

USAePay has identified the issue and is working on solution. They have mitigated traffic to stabilize the issue and are monitoring for stability.
Posted Sep 02, 2026 - 09:49 PDT

Update

We have identified the issue with the upstream provider causing some Card Not Present transactions for some customers to fail. We are working to resolve the issue as quickly as possible.

Please re-try failed transactions.

If you continue to have difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Sep 02, 2026 - 09:10 PDT

Identified

We have identified the issue with the upstream provider causing some Card Not Present transactions for some customers to fail. We are working to resolve the issue as quickly as possible.

Please re-try failed transactions.

If you continue to have difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Sep 02, 2026 - 07:24 PDT

Investigating

We are currently investigating an issue causing some transactions for some customers to fail.

If you are having any difficulties, please contact our support team at support@gravitypayments.com or call tel:8667014700.
Posted Sep 02, 2026 - 07:05 PDT
This incident affected: Processing Services.